GIS Blog

Fixing Common ArcGIS Problems

This post covers some of the common problems that arise with ArcGIS, and how to fix them.

There’s no getting around the fact that GIS is frustrating.  And it doesn’t get any better as you do; the problems just transmogrify into different kinds of challenges.  In this post we’ll look at the top five common problems encountered with ArcGIS (Ed. what, only 5?!?) and hopefully their fixes.  You’ll see that there are actually six problems listed below – one of them has no easy fixes.

Tool Not Licensed

This is one of the most common problems arising.  You go to use a tool from ArcToolbox and get this:

For many, this is the first of many unexplained ArcGIS errors – but it’s one of the easiest to fix.  There are several built in “extensions”, like Spatial Analyst and 3D Analyst, that provide extra functionality.  Back in the day, they had to be purchased separately and had their own licenses and needed to be “turned on”.  We have access to them through our academic site license.  To fix this problem, go the menus at the top of ArcMap (or ArcCatalog) and look for “Customize” (sic).  Under that menu, go to Extensions and tick the box next to the extension listed in the error message – Spatial Analyst in the above example (probably the most common one):

This should fix that problem.

Red exclamation marks

Sometimes it happens when you open an ArcMap map and you see the dreaded red exclamation marks:

These occur when ArcMap can’t find the layers that are on the map.  They can be fixed by redirecting ArcMap to look in the right location.

A quick aside about map documents.  The main function of a map document is to store all the settings for your map.  It keeps track of what layers are on the map as well as how you’ve symbolised your map in the same way that a Word document stores all your changes.  It also keeps track of tools that you’ve run.

An easy way to see where the map document is looking is to click the “List by Source”
button, . When clicked, the path to each layer is shown in the Table of Contents:

We can see that it’s looking in J:\Data\Coastline for the “coastline” layer – and has found it.  This isn’t so helpful for the other layers so let’s dig deeper by right-clicking on one of the layer names and going to Properties > Source:

So it’s looking for a Rivers shapefile in J:\Courses\ERST202\WMS.  Let’s have a look in that folder and see why it’s not finding it:

So this appears to be the problem – this must be a very old map document because now those layers are in a geodatabase rather than as separate shapefiles.

Even though the layer name is the same, it’s in a different format so as far as ArcMap is concerned, what it’s looking for isn’t there, hence the red exclamation mark.

Happily it’s pretty easy to fix and we are now armed with the information we need – the path to the proper layer.

Back in ArcMap, you can either go back to Properties > Source, click the “Set Data Source” button and redirect it, but you’ll have to do this layer by layer.  Alternatively, click on the mark itself and redirect there:

That should deal to the mark:

As a double bonus, doing it this way has reset the paths for the other vector layers.  Doing the same with one of the raster layer should fix the three en masse.

As a side note – this often happens when copying maps and data between places.  Say you’re working on a map on your H: drive and you want to work on this on your laptop or home computer.  So you dutifully copy everything to a USB drive and then copy to a new location on a different computer.  When you open the map, it’s awash in red.  Happily, again, there’s an easy way to prevent this before you copy.  First, make sure your data and map are in one folder.  Second, go to File > Map Document Properties and tick the wee box at the bottom reading “Store relative path name to data sources”:

This simply means that ArcMap is going to disregard the whole path and just look in the local folder for the data.

In this example, it would ignore “H:\” and just look in the ERST202 folder.

This could save you a lot of heartache but does mean that you’ve got to be aware of where all your layers are and that they’re all in the same place.

It might mean copying/clipping layers from off of J: and into your transportable folder as your laptop at home won’t be able to find the J: drive very easily.

(Another option is to use Dropbox to keep all your files in one place.  You could try this with OneDrive, but I would wouldn’t recommend it.)

 

Missing Table of Contents

Sometimes, your Table of Contents simply goes missing:

It’s like getting in the car and the steering wheel is gone.  Here’s the quick and easy fix.  From the menus go to the Window menu and you’ll see you can click on the Table of Contents:

Can’t add a field

Adding a new field is a fundamental thing with attribute tables but sometimes when you go to add a field, you see this:

“Add Field…” is greyed out.

This happens if you’ve got an editing session open, which pretty much locks up making changes like this.

The easiest thing to do is to stop your editing session (and save any changes!), come back and add your field and then reopen your editing session.

 

 

 

But sometimes you get something like this:

You’ll come across this one when you’re not in an editing session and the other “application/user” is invariably ArcCatalog.  If you’re previewing that particular layer in Catalog, it “locks” the layer, preventing you from making any changes to the data.  Closing ArcCatalog is the easiest fix to this problem.

Error 001143 – Background server threw an exception

This one is also relatively common – you’re running a tool and it fails with this error.  I’ve yet to fully understand why this happens, but still it does – quite regularly.  By default, tools are run “in the background” meaning that while a tool is running you can do other stuff with ArcMap.  When a conflict arises, the part of the code that does this (the background server) throws an exception (the actual technical term is “throws a wobbly”).  You can fix this by going to the Geoprocessing Menu and looking for “Geoprocessing Options”.  In the window that pops up, untick the Enable Background Geoprocessing:

The downside of this is that you won’t be able to do other work until the tool has finished its work.

Error 999999 – Something unexpected caused the tool to fail

Most everyone will have experienced this one.  Often when a tool fails to run, you can get a bit of feedback on why it did so.  Here’s an example – I’ve run the Contour tool so that I get an error (I was having a lot of problems that day…):

(Helpful hint – check out the processing results by going to GeoprocessingResults.  I have this tab always open in my Table of Contents – you can dock it there)

With most errors you get some information that will help solve the problem.  But error 999999 is not one of them.  It might as well be 666.  These errors require a lot more work to figure out and often, simple closing and reopening your map document will help (but not always).  In this case I did get a little bit of helpful info, but not much really.  By their own admission, ESRI says:

So even they don’t know what went wrong.  If they persist, try here.  And may the Force be with you.

 

Making ArcGIS work faster in general

There are a lot of tips and tricks to getting the most out of ArcGIS.  Here’s a good summary of things that help.  The built in basemaps can often slow up ArcMap’s ability to get things done and working locally is often a good option if you can.  There’s always been a bit of a conflict with ArcGIS and our network but I have yet to find a way to improve that.

Hope you find one or more of these helpful.  There’s no getting around the cold, hard fact that working with GIS is frustrating.  But hopefully the pain is worth the benefit.  The only fitting way to end this post is with the inevitable window that we will all face before we cross the River Styx:

C

• February 21, 2019


Previous Post

Next Post

Leave a Reply

Your email address will not be published / Required fields are marked *